Salesforce 1 Android OS Issues

Dec 30 2013By Murray Grevious

CRM1
When Salesforce1 was released at Dreamforce, we were all ecstatic to take it for a test drive. The app itself is wonderful and will open up a whole new world of functionality to Salesforce mobile users. However, we have discovered that the Salesforce 1 application requires Jelly Bean 4.2 Operating System or higher to operate correctly.

The Jelly Bean OS spans versions 4.1 to 4.3, so even if you have Jelly Bean, you may not meet the system requirements. Around 35-40% of Android users are running the Jelly Bean 4.1.2 operating System. Of those, only a handful are capable of upgrading to Jelly Bean 4.2.••

As a result, anyone downloading the application off of Google Play with this OS version or older will receive a slimmed down version of SF1 similar to the original Chatter Mobile app. If your OS is one of the early versions, such as Ice Cream Sandwich or Honeycomb, you may be unable to open the application at all.

We are looking to bring the severity of this issue to the attention of Salesforce. Please support this idea from the Idea Exchange asking Salesforce to change this requirement and open up Salesforce1 to all Android OS users: https://success.salesforce.com/IdeaView?id=08730000000ky5fAAA# Android is too popular to be left out of the loop, so please vote and get this issue noticed!

••Please see these websites for some examples of devices that can’t be upgraded:

http://www.droidviews.com/verizon-droid-razr-hd-and-maxx-hd-update-incoming-still-android.4-1.2/

http://www.droid-life.com/2013/12/15/droid-maxx-ultra-and-mini-soak-test-set-to-start-soon-surprised-if-it-isnt-kit-kat/


Get the Blog Newsletter

Follow Us


TechnoMile on Twitter